LuaSQLite3

Check-in [393151db27]
Login

Many hyperlinks are disabled.
Use anonymous login to enable hyperlinks.

Overview
Comment:Update rockspec and HISTORY
Downloads: Tarball | ZIP archive | SQL archive
Timelines: family | ancestors | descendants | both | fsl_9b | trunk
Files: files | file ages | folders
SHA1: 393151db27247612a73364e76ceb3cb67d384826
User & Date: e 2013-04-08 17:08:37
Context
2013-05-06
20:45
Update rockspec to indicate compatibility with Lua 5.1 and 5.2 but not Lua 5.3 check-in: 89c917f576 user: e tags: fsl_9t, trunk
2013-04-08
17:08
Update rockspec and HISTORY check-in: 393151db27 user: e tags: fsl_9b, trunk
16:52
Updated example and test files from Dmitry check-in: 5282faf755 user: e tags: trunk
Changes
Hide Diffs Unified Diffs Ignore Whitespace Patch

Changes to HISTORY.









1
2
3
4
5
6
7
8
9
10

11
12
13
14
15
16
17
18
19








2013-March-30

Version "0.9-devel"

Since the "0.8-devel" release of this Lua library...

Updates for Lua 5.2 (backward compatible with Lua 5.1.5).

Uses lunitx-0.6-1.rockspec for Lua 5.2 compatible testing.


Added sqlite3.update_hook() at the suggesiton of Dmitry Pashkevich,
who also contributed some testing assistance on this release.

Converted Makefile to depend on luarocks.

2011-January-10

Version "0.8-devel"

>
>
>
>
>
>
>
>










>
|
|







1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
2013-April-08

Version "0.9.1-devel"

Since the "0.9-devel" release of this Lua library...

Updated examples and tests from Dmitry Pashkevich.

2013-March-30

Version "0.9-devel"

Since the "0.8-devel" release of this Lua library...

Updates for Lua 5.2 (backward compatible with Lua 5.1.5).

Uses lunitx-0.6-1.rockspec for Lua 5.2 compatible testing.

Added sqlite3.update_hook(), sqlite3.commit_hook() and 
sqlite3.rollback_hook() at the suggesiton of Dmitry Pashkevich, who 
also contributed examples and some testing assistance on this release.

Converted Makefile to depend on luarocks.

2011-January-10

Version "0.8-devel"

Name change from lsqlite3-0.9-1.rockspec to lsqlite3-0.9.1-1.rockspec.

1
2
3
4
5
6
7
8
9
10
11
12
package = "lsqlite3"
version = "0.9-1"
source = {
    url = "http://lua.sqlite.org/index.cgi/zip/lsqlite3_fsl09.zip?uuid=fsl_9",
    file = "lsqlite3_fsl09.zip"
}
description = {
    summary = "A binding for Lua to the SQLite3 database library",
    detailed = [[
        lsqlite3 is a thin wrapper around the public domain SQLite3 database engine. 
        The lsqlite3 module supports the creation and manipulation of SQLite3 databases. 
        After a require('lsqlite3') the exported functions are called with prefix sqlite3. 

|

|
|







1
2
3
4
5
6
7
8
9
10
11
12
package = "lsqlite3"
version = "0.9.1-1"
source = {
    url = "http://lua.sqlite.org/index.cgi/zip/lsqlite3_fsl09b.zip?uuid=fsl_9b",
    file = "lsqlite3_fsl09b.zip"
}
description = {
    summary = "A binding for Lua to the SQLite3 database library",
    detailed = [[
        lsqlite3 is a thin wrapper around the public domain SQLite3 database engine. 
        The lsqlite3 module supports the creation and manipulation of SQLite3 databases. 
        After a require('lsqlite3') the exported functions are called with prefix sqlite3.